Getting Started

From OpenRocket wiki
Jump to: navigation, search
← Downloading & Installing
Basic Rocket Design →

↑ Back to Contents

The current User's Guide is very much a work in progress, any help would be greatly appreciated!
If you'd like to contribute something, just hit the 'Edit' tab at the top.

3. Getting Started[edit]

In this section we have a look at how OpenRocket is organized, by analyzing in detail the structure of the user interface. We will also briefly mention the Example projects that are accessible from the File menu. After reading this section you will have a thorough understanding of how OpenRocket is structured, and will be ready to start designing a rocket of your own. If you already know how this program is organized, feel free to jump to the next section.


The User interface[edit]

In this subsection we first briefly discuss the Rocket Configuration window, and then OpenRocket's main window and the main window's four menus.


The Rocket Configuration window[edit]

When you start a new project, you will be prompted with the following window:

The Rocket Configuration window.

Fill in the four fields (or you can leave all, except the Design name, blank if you wish), and click the close button.


OpenRocket's main window[edit]

You now have access to the OpenRocket main window.

The OpenRocket main window.

Notice there are two tabs in the top-left corner of the window, just under the menu options. These tabs allow you to switch between the Rocket design and Flight simulations windows.


The Rocket design window[edit]

For the moment, let's focus on the Rocket design window. This window is organized in the following way:
- in the bottom half of the window there is a large white space. This is where a 2D image of the rocket you are designing will appear.
- in the top-left part of the window, the rocket's stages and components are shown. When you start a new project, the rocket contains only one stage (i.e.; the sustainer) but no components.
- in the top-right part of the window, all the body components and fin sets, inner components, and mass objects that you can add to the rocket are shown. Notice that it's not possible to add all of these objects to the rocket at any particular stage of the rocket design. Exactly which components can be added when will be explained later in this guide.

Now let's have a closer look at the bottom half of the Rocket design window. When you add a component to your rocket, it will be immediately displayed, as shown below:

Bottom half of the Rocket design window after adding a nose cone.

Notice the rulers around the borders. These give you an idea of the dimensions of your rocket.

As you can see, in addition to the appearance of your rocket, the Rocket design window also shows some other useful information as well. This includes the rocket's dimensions, mass, apogee, max. velocity, max. acceleration, stability, center of gravity (CG), and center of pressure (CP).

In the top left-hand corner of the previous image there are two buttons: Side view and Back view. These allow you to visualize the rocket from two different positions. Next to these buttons you can find the zoom-regulation commands and then one Stage i button for each Stage in your rocket. Selecting/deselecting each of these allows you to include or exclude each stage from the picture. On the left of the previous image you can also see a scroll bar that allows you to rotate the rocket up to 360°.

Finally, notice the drop-down list in the top right-hand corner of the previous image. This allows you to choose which of your motor configurations to apply to the rocket you have designed (more on this later). The image below shows how the bottom half of the Rocket design window appears after the rocket design has been completed.

Bottom half of the Rocket design window after completing the rocket's design (taken from the A simple model rocket example design).

In this image, the rocket's body components and fin sets are represented with a continuous blue line; the rocket's inner components are represented with a continuous red line (the inner tube is also filled in with a grey background); and the mass objects are represented with either black or red dotted lines. It is also possible to customize the colour in which each part is represented, as will be shown later on. The image below shows how the top left-hand portion of the Rocket design window looks after the rocket design has been completed.

Top left-hand portion of the Rocket design window after completing the rocket's design (taken from the A simple model rocket example design).

As you can see, the rocket's components have a tree-like structure:
- the Rocket, called A simple model rocket, has only one stage: the Sustainer.
- the Sustainer contains two body components: a Nose cone and a Body tube.
- the Body tube contains a fin set (in particular a Trapezoidal fin set), a Launch lug, three inner components (an Inner Tube and two Centering rings), and three mass objects (a Shock cord, a Parachute, and a Wadding).
- the Inner tube contains an Engine block.
This tree-like structure will be discussed further later in this guide.

The buttons visible on the left in the previous image have pretty straightforward functions. By selecting one of the rocket's components you can change its position in the list of components (but not its position in the rocket) by using the Move up and Move down buttons. You can also edit its characteristics (e.g., dimensions, material, mass, colour used to represent it within the rocket) by using the Edit button--or you can delete it from the rocket completely using the Delete button. Notice that none of these buttons is active in the above image, since no component has been selected.

You can also add an extra stage to your rocket by clicking the New stage button.


The Flight simulations window[edit]

Now we have a look at the Flight simulations window, which you can access by selecting the Flight simulations tab in the top left-hand corner of the OpenRocket main window. Before designing your rocket or running any flight simulation, the Flight simulations window looks like this:

The Flight simulations window before designing the rocket and running any simulation.

Notice that the bottom part of the window does not change when switching from the Rocket Design window to the Flight simulations window. Hence we only need to analyze the top part of the window. Here, most of the space is occupied by a currently blank space, where the technical details about your simulations will appear. Above this space there are five buttons, which allow you to program a new simulation (New simulation), edit a selected simulation (Edit simulation), for example by changing motor configuration or some atmospheric condition, run all the simulations you have programmed (Run simulations), remove the selected simulations (Remove simulations), or either plot or export some of the results of a selected simulation(Plot/export). (More on exporting simulation results in Section 8.)

The image below shows how the top part of the Rocket Design window looks after you have designed your rocket, programmed some simulations and run them.

The top half of the Flight simulations window after having programmed and run some simulations (taken from the A simple model rocket example design).


Notice that five of the six simulations that have been run have a green tick on the left: this means that the simulation has been completed without any warnings. Conversely, if the simulation has generated some warning while being run, a red exclamation mark is shown (as for the third simulation in the image above). To find out the more about the warning, mouse-over the simulation (without clicking) as shown in the image below.

More information about warnings in the Flight simulations window.


It is possible to change the position of the columns containing the various technical simulation data by simply dragging any column left or right, as shown below:

Moving columns in the Flight simulations window.


The main window's menus[edit]

We now analyze the four main window's menus, briefly explaining the function of each of the menus' options.


The File menu[edit]

The image below shows the options offered by the File menu, located in the top left-hand corner of OpenRocket's main window.

The File menu.

The function of each option in the File menu is pretty straightforward to understand:
- New allows you to start a new project, without closing the project that is currently open.
- Open... allows you to open a *.ork file that you have saved on your computer.
- Open example... allows you to open one of the example projects (more on these later).
- Save saves the changes you have made to a previously-saved project.
- Save as... allows you to save the project you are working on to a new *.ork file.
- Print/Export PDF opens a window like the one shown below (if you have already completed your rocket's design). From here you can select what to include in your print/PDF file; such as technical details of your rocket's components, templates of your rocket's fin sets or even the design of your rocket. We suggest you try this option with one of the example projects to understand how each of these is represented when printing/exporting to PDF. More on printing and exporting to PDF in Section 8.
- Close closes the current project (after asking for confirmation if there are unsaved changes). This will also exit the application if there was only one project open.
- Quit exits the application, checking that you have saved all open projects.

The window that opens when Print/Export PDF is selected.


The Edit menu[edit]

The image below shows the options offered by the Edit menu.

The Edit menu.

These options are mostly the classic editing options: undo/redo some action (Undo/Redo) and cut/copy/paste/delete some element (Cut/Copy/Paste/Delete). We also have the following options:
- Scale... opens the window shown below. Here you can choose to scale your rocket's size by some percentage (you can select from a range of 25% to 400%), starting from a specified dimension that can either be the one the rocket currently has or one you specify. By checking or unchecking the Update explicit mass values box, you can also decide whether or not the rocket's mass should be updated when scaling its volume.

The Scale window.

- Preferences opens the Preferences window, as shown below. At the top of this window there are three tabs which allow you to switch between Units, Materials, and Options. We will first consider the Units tab (shown in the picture below). Here you can set the units for each individual physical quantity, or set all units either to the Default metric or to the Default imperial settings.

The Units tab of the Preferences window.

The picture below shows the Materials tab of the Preferences window. Here you can manage all of the available materials for the rocket component, by either editing the characteristics of the materials (i.e., their name and density) through the Edit button, or you can delete a material through the Delete button. You can also add new materials if you wish, by clicking the New button and setting the material's name, type and density.

The Materials tab of the Preferences window.

Finally, the picture below shows the Options tab of the Preferences window. Using the provided drop-down lists you can set the application's language, determine where to insert new rocket components, choose whether or not to ask for confirmation when deleting simulations, or load some of your own thrust curves.

The Options tab of the Preferences window.


The Analyze menu[edit]

The image below shows the options offered by the Analyze menu.

The Analyze menu.

- The Component analysis option opens a window like the one shown below. Here, technical information for the rocket's external components and fin sets is displayed. Using the scroll bars in the top half of the window you can also change some parameters, such as wind direction, angle of attachment, mach number and roll rate. More on the component analysis window in Section 8.

The Component analysis window, opened from the A simple model rocket example design.

- The Rocket optimization option opens a window like the one shown below. From here you can optimize the performance of your rocket by selecting exactly which performance to optimize from the Optimized drop-down list. More on the rocket optimization window in Section 8.

The Optimization window, opened from the A simple model rocket example design.

The Help menu[edit]

The image below shows the options offered by the Help menu.

The Help menu.

NOTE: The guided tour option is a planned feature, but is not yet implemented in OpenRocket. Therefore for the moment you will not find it in the Help menu.
The functions of the options in the Help menu are as follow:
- License opens a window containing OpenRocket's license.
- Bug report opens a bug report form that you can complete and submit to the developers.
- Debug log opens the OpenRocket debug log.
- About opens a window containing summary information about this project.

The Example projects[edit]

By now you should have a good idea of how OpenRocket's user interface is structured, so you might feel ready to start designing your own rocket (see next section)--and probably you are indeed ready. Nonetheless we suggest you have a look at some pre-designed example rockets that we have provided. To do this, simply select File -> Open example... and the window shown in the image below will appear.

The Open example design window.

Select one or more of the listed rockets (we suggest that you start with A simple model rocket), then click Open. Now have a closer look at the various windows discussed in this section, and note how they change when you choose another example project. This should give you an idea of how to best use this application, and maybe even give you some new ideas for your future rockets!

Now that you know how this program is structured, you can start using OpenRocket to design your own rockets. How to do this will be the topic of the next section.


← Downloading & Installing
Basic Rocket Design →

↑ Back to Contents